Back to overview
Resolved
Panel Migration
May 7, 2026 at 9:00pm UTC
–
May 7, 2026 at 11:30pm UTC
Affected services
Control Panel
Resolved
May 7, 2026 at 11:30pm UTC
Maintenance ended
Affected services
Updated
May 7, 2026 at 9:59pm UTC
- 30 Minutes
Affected services
Created
May 7, 2026 at 9:00pm UTC
We are moving to a completely different game panel. The serves wont be affected at all.
The only thing is that the panel will be down during the maintenance.
Affected services