Back to overview
Resolved
Panel Update
May 30, 2026 at 12:11pm UTC
–
May 30, 2026 at 12:45pm UTC
Affected services
Control Panel
Resolved
May 30, 2026 at 12:45pm UTC
Maintenance ended
Affected services
Created
May 30, 2026 at 12:11pm UTC
Small maintenance to fix some minor issue. Only panel affected.
Affected services